Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I seem to be getting this annoying error intermittently.

Although my internet connection is working fine the Connect To dialog insists that I can't connect to my VPN connections as there isn't an active connection. If I dig down to the actual Control Panel > Network Connections screen I can connect the the required connection without any problems so this is an annoyance rather than a major issue but I thought I'd see if anyone knows of a permanent fix to this.

I've already tried amending the binding order to make sure my LAN is listed before anything else which hasn't helped.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I am having the exact same problem, what triggers it for me, is VMware Workstations 2 Network interfaces, if I disable either “VMware Network Adapter VMnet8” or “VMware Network Adapter VMnet1” I can use the “Connect To” windows just fine, if however they both are enabled it says there is no active connection.

Do you by any chance have VMware Workstation / (Or Player) installed with both interfaces enabled?

I did the interface bindings trick aswell, but that didnt help, the above with disabling one of the two VMware interfaces did however, i have yet to find out why this happens.

share|improve this answer
    
Interesting point - I forgot to mention it but I'm running VMWare Server on this box. I guess this could be the cause but it's a little strange. I've been running fine with this set-up for a number of months - its only over the last few weeks that i've started getting this VPN problem. –  Chris W Jul 21 '09 at 7:32

I've had numerous VPN stability issues in both Windows Vista and Windows 7 when VMware Workstation is installed on the machine. I have a Vista machine that experiences the exact behavior mentioned in the OP's question.

An alternative to disabling one of the VMware Network Adapters is to kill the various vm* services that launch at startup when you're not using them (or prevent them from starting to begin with). This seems to improve VPN functionality for me as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.