Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

System is Windows 2008 R2

I have a task scheduler task with a trigger to run at system startup, and have set the Delay to 20 minutes, however the task runs immediatley on system startup and ignores the 20 minute delay. There are other triggers, but it is the boot trigger which is at fault by ignoring the delay.

Triggers section of the exported task follows.

  <Triggers>
<CalendarTrigger>
  <StartBoundary>2009-12-29T08:35:00</StartBoundary>
  <Enabled>false</Enabled>
  <ScheduleByWeek>
    <DaysOfWeek>
      <Monday />
      <Tuesday />
      <Wednesday />
      <Thursday />
      <Friday />
    </DaysOfWeek>
    <WeeksInterval>1</WeeksInterval>
  </ScheduleByWeek>
</CalendarTrigger>
<BootTrigger>
  <Enabled>true</Enabled>
  <Delay>PT20M</Delay>
</BootTrigger>
<CalendarTrigger>
  <StartBoundary>2012-07-29T18:07:16</StartBoundary>
  <Enabled>true</Enabled>
  <ScheduleByWeek>
    <DaysOfWeek>
      <Monday />
      <Tuesday />
      <Wednesday />
      <Thursday />
      <Friday />
    </DaysOfWeek>
    <WeeksInterval>1</WeeksInterval>
  </ScheduleByWeek>
</CalendarTrigger>

share|improve this question

I added a new task with only one trigger - the BootTrigger with delay. This time the delay did work. So there must be some bug where a boot trigger delay does not work if multiple triggers are present.

share|improve this answer

I was able to get a delay working with multiple triggers. I had to to change the "Configure for:" setting on the first tab to "Windows 7/Windows Server 8 R2".

The task xml file task tab now says <Task version="1.3" instead of <Task version="1.1". There are a lot more settings in version 1.3 than version 1.1.

In my case I was adding a delay after any user logs on. I tried to manually add a delay tag <Delay>PT15M</Delay> under <LogonTrigger> for version 1.1 to the task xml file to import into task scheduler, but task schedular returned an error that it was an invalid setting. For version 1.3 however it works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.