Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed NIS server on head node of a virtual cluster(VirtualBox). One of the node (let's say node-1) can find NIS server and work with it, but another node (node-2) just can't find the NIS server in Yast while it can ping and ssh to both head node and node-1. BTW, all the nodes are VMs, head node and node-1 are on the same physical machine, node-2 is on another physical machine.

I set the domain name in /etc/hosts and /etc/yp.conf, and ypwhich sometimes gives the correct domainname several minutes later complains about "ypwhich: Can't communicate with ypbind", and will back to work after some time. Also tried rpcinfo -p hostname and it worked as expected.

I almost tried every thing I can find on internet, but seems that not many people had this problem.

Any help would be very appreciated.

share|improve this question
domainname [domainname]
ypdomainname [domainname]
service ypbind restart

What does that give you?

share|improve this answer
domainname gives correct domain name, so does ypdomainname, after restart ypbind, Yast still can't find NIS server. – Tony Sep 17 '12 at 14:22

Are you sure the hosts listed in /etc/yp.conf are NIS masters or slaves? You might want to amend the problem and attach a copy of the /etc/yp.conf file. Have you checked for a syntax error in this file?

Next, do any of the NIS master or slave server have IP protection via the securenets if I recall the filename? If so, an administrator will have to change this.

Those are my suggestions of areas.

share|improve this answer
Thanks for the answering. The content in /etc/yp.conf looks like ypserver domain nis.sirius broadcast domain broadcast which I copied from the node-1 which is working. I only have master, no slave NIS server. ypwhich also gives correct domainname. I have sudo permission, how should I check if it's the IP protection problem? The Google result for it is not clear. – Tony Sep 17 '12 at 17:28
up vote 0 down vote accepted

I finally solved the problem by disabling firewall on NIS client side.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.