Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My stunnel implementation works fine when the network is plugged in but it takes an awful amount of time, which delays the whole boot process, when there is no network connected to the machine.

As extra information:

  • I'm using "delay=yes"

  • I'm using an fqdn (e.g: for the connections

  • Using ubuntu but this also happened with centos5 previously

How can this be avoided or a timeout specified?

edit: doing an strace as suggested by symcbean shows the following (including the last part where it hangs):

--- SIGCHLD (Child exited) @ 0 (0) ---
rt_sigreturn(0x11)                      = 0
close(3)                                = 0
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 6039
clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7ff9ce0c79d0) = 6046
wait4(-1, [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 6046
--- SIGCHLD (Child exited) @ 0 (0) ---
rt_sigreturn(0x11)                      = 6046
write(1, "[Started: /etc/stunnel/stunnel.c"..., 37) = 37
write(1, "stunnel.\n", 9)               = 9
exit_group(0)                           = ?

stunnel hangs in this line: wait4(-1,

and when i plug in the network cable it continues to show [{WIFEXITED(s) && WEXITSTATUS(s) == 0}], 0, NULL) = 6046

share|improve this question
Have you tried doing a packet capture/strace when you start up the daemon on a running system? – symcbean Sep 17 '12 at 12:43
output added to the original question as there is limit on chars on comments. – Onitlikesonic Sep 17 '12 at 15:18
correction, stunnel doesn't start at all, left a machine booting for 30+ minutes and nothing – Onitlikesonic Sep 18 '12 at 14:01
up vote 0 down vote accepted

It appears this has now been solved with the latest update

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.