Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got Windows Server 2k3 with IIS6 hosting a couple ASP.NET MVC 2 applications (.NET 4), all in the Default Web Site. Most of them simply use Integrated authentication, but a couple use forms as well. All the applications work properly and are correctly accessible.

The problem I'm trying to resolve is access to the default document. It is currently specified as index.htm. Both index.htm and the Default Web Site are configured to allow anonymous access (with none of the authenticated acces boxes checked). However, access is denied to the file.

Accessing via server.domain.tld/ and server.domain.tld/index.htm both yield 401 errors. However, server.domain.tld/default.htm (file does not exist) properly returns a 404.

If I alter the file security on index.htm to allow integrated authentication, then requesting /index.htm directly works properly for users with domain accounts, but anonymous users get a login prompt/401.

How can I configure IIS to allow all users to view index.htm via server.domain.tld/?

share|improve this question

1 Answer 1

File permissions for anonymous access are set via a special user account called IUSR_<MachineName>.

Check the NTFS permissions (Security tab) of both your document root folder and the index.htm file itself. Verify that this account has "Read" access to all of the files and folders that anonymous users need to be able to browse.

If this account is not listed, or if it does not have all of the default read permissions, try adding it with the default "Read" permissions. (Of course, you should not give this account "Modify" or "Full Control" permissions.)

For more detailed information, refer to Microsoft's tutorial on how to set required NTFS permissions and user rights for IIS6.

share|improve this answer
    
I've verified that both the directory and index.htm have this setting for the IUSR_ account, but still recieve 401 when trying to access it. –  Jim Oct 1 '12 at 18:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.