Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

The issue is that when downloading the file, the download occurs (first prompt to open/save) and you can save the file. If you OPEN the file, it will make additional OPTIONS requests to the wiki server, and one of these requests do not pass the authenticated credentials which causes a user/pass login prompt. (the user can cancel this prompt and everything works as expected)

2 current workarounds:

  • Click save, then open on the second prompt.
  • Click cancel on the prompt after clicking Open on the save/open prompt.

We're using MediaWiki if that matters, but it appears to be specific to IE and downloading xlsx or docx file attachments. The user is using IE8, and logs into the wiki using Trusted Sites zone, so they log into via domain credentials.

Viewing the requests in fiddler show the user agent as "Microsoft-WebDAV-MiniRedir/6.1.7601" and they are requests for the current file, current directory, then every parent directory.

Example requests:

User request:

GET /images/x/x1/Filename.xlsx

When Open is chosen the following requests are made:

OPTIONS /images/x/x1/
OPTIONS /images/x/
OPTIONS /images/
OPTIONS /
OPTIONS /

On the second OPTIONS request, it drops all cookies, so they are asked to log back in to the trusted site.

Is there a setting or maybe even a response I could set in Apache to prevent this prompt?

Let me know if you need additional information, I'm afraid I might have been rambling.

Thanks, Andy

share|improve this question
    
I know I have had the same issue from our Apache based-wiki, but I cannot recall our solution. It might have been by setting the dword of ForceShellExecute to 1 under HKLM\SOFTWARE\Wow6432Node\Microsoft\Office\12.0\Common\Internet. But my notes aren't complete, and that could have been to fix a different issue. –  Zoredache Sep 17 '12 at 18:40
    
Seen similar issues with authenticating proxies - in that case moving from NTLM to Kerberos seemed to resolve the issue. It appears that when you chose "open" IE passes the request off to office as a URL rather than downloading and pointing at a temp file. I wonder if there's a way to stop that? –  Tom Newton Sep 17 '12 at 22:44
    
@Zoredache Thanks, I'll play around with that, though I'll have a hard time getting our IT to set that on every PC. –  Andy Sep 18 '12 at 15:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.