Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a farm of IIS servers running Exchange and we are getting this error in HTTP Error:

HTTP/1.1 POST /ews/exchange.asmx - 1 Connection_Dropped_List_Full MSExchangeServicesAppPool

The advice from MSFT is to increase the app pool queue length from 1,000 to 10,000

How do I change IIS's MSExchangeServicesAppPool to a new value via the command line

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The correct syntax can be found on IIS.NET site.

To change the queue length you would have to enter:

appcmd.exe set APPPOOL "DefaultAppPool" /add.queueLength:10000

in your case:

appcmd.exe set APPPOOL "MSExchangeServicesAppPool" /add.queueLength:10000

You can list the current configuration settings with:

appcmd.exe list APPPOOL "MSExchangeServicesAppPool" /text:*

Hope this helps.

share|improve this answer

I don't have a way to test this right now, so this might not work. That said you might be able to change this using appcmd (http://www.iis.net/learn/get-started/getting-started-with-iis/getting-started-with-appcmdexe) to change the queue length - it's in applicationHost.config (http://www.iis.net/configreference/system.applicationhost/applicationpools/add)

for example

%systemroot%\system32\inetsrv\APPCMD set apppool "MyAppPool" /add.queueLength 10000
share|improve this answer
    
Nearly got it right. –  hot2use Apr 7 at 13:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.