Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have the following:

  • QNAP EC12xxx series with 36TB.

The QNAP comes with default folders such as Public, Downloads, Web, Usb etc etc. These cannot be deleted!

In windows I can write to all these shares" with NO problem, either copy and past or drag n drop.

Work Perfectly

The Issue

We are testing a video rendering software. Where it has watch folder, Video In > Process > Video Out.

Now, here is the strange thing I do not understand. If I use the Public Share, everything works.

If I have the VIDEO OUT folder under the share of WEB. I get an error. Saying the program has an I/O error, unable to copy to location xxx.xxx.xxx.xxx./web/video out. However If I copy the file myself, i.e. copy n past or drag n drop. it works.!!!!!!! But if the software tries to output the files DIRECTLY to the WEB share it does not work.

My thoughts

  • I have confirmed it is nothing to do with permissions, well to the best of my knowledge but I could be wrong.
  • The system works under the share of Public there for it cannot be the software
  • The system also works if I create a new share e.g. TEST SHARE.
  • So for me, it has something to do with the QNAP system which is based on Linux, however I am not sure what. The fact I can copy n past works perfectly and that the video system cannot export directly to the WEB SHARE is confusing me a little
  • I have also tried a TEMP scratch folder. The video is rendered to the LOCAL drive or a network drive and then moved once the job is complete. However this does not work as well.

Thanks

share|improve this question
    
Is it because there's a space in the name of the folder? –  user3914 Sep 18 '12 at 16:58
    
@RandolphWest Have tried before, still no go... –  Arthor Sep 19 '12 at 13:15

1 Answer 1

up vote 0 down vote accepted

In-depth permission needed to be set, need to contact QNAP support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.