Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not exactly sure what went wrong but our SQL Server Reporting Services authentication is no longer working correctly. When I try to load the site, it asks for a username and password, and mine doesn't work.

I checked the service and it is using the NT AUTHORITY\NetworkService to logon. Since it is using NetworkService to logon, I read on Microsoft's site that I need to use these settings in the RSReportServer.config file:

<AuthenticationTypes>
    <RSWindowsNegotiate />
</AuthenticationTypes>
<EnableAuthPersistence>true</EnableAuthPersistence>

Which is what I have set. It still asks for the password. When I set the Authentication to RSWindowsNTLM, it does login but everytime I click on a link, it asks for a password (the password doesn't seem to prevent anything from loading).

I have logged in the log file and there isn't anything telling there.

Anyone know what is going on here? I'm not an expert on SQL Server so I may be missing something.

share|improve this question
    
Not to be flippant, but have you tried rebooting the server? –  joeqwerty Sep 18 '12 at 20:44
    
Yes I have. This has been an ongoing issue for several months. –  Keith Sep 19 '12 at 12:11
    
Are you using IE? If so, have you tried changing the user authentication to automatic login? –  JMeterX Sep 21 '12 at 5:02
    
Yes I am testing it with IE as well as Chrome. Can you explain what you mean? The <RSWindowsNegotiate /> should make it login automatically. –  Keith Sep 21 '12 at 12:25
    
Was your SQL server renamed? –  Serhiy Sep 25 '12 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.