Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to manually run a systemstatebackup command on my server 2008 r2 box and I am getting an error code '2155347997' when I view the backup event log details. The command line tells me that I have log files written to the c:\windows\logs\windowsserverbackup\ path but I have no files of the .log type there.

My command window tells me "System Writer is not found in the backup". However when I run vssadmin list writers I find System Writer in the list and it shows normal status with no last errors stored.

I am running this from an elevated command prompt as well as from a logged on administrator account. My backup target path has permission for network service to have full control and it has plenty of free space.

Looking in eventlog I have two VSS error 8194 that happen immediately before the Backup error 517 which has the errorcode 2155347997 listed. All three of these errors are a result of trying to run the command for the systemstatebackup.

It's my belief that some VSS related permission is failing and exiting the backup process before it ever gets started. Because of this the initial code that creates the log files must not be running and this is why I have no files. When running the systemstatebackup command from the command prompt and watching the windowsserverbackup directory I do see that I have a Wbadmin.0.etl file which gets created but it is deleted when the backup errors out and stops.

I have looked online and there are numerous opinions as to the cause of this error. These are the things I have corrected to try and fix this issue before posting here:

  1. Machine runs a HP 1410i smart array controller but at one time also used a LSI scsi card. Used networkadminkb.com's kb# a467 to find one LSI_SCSI entry in HKLM>Sys>CurrentControlSet>Services which start was set to 0x0 and I modified to 0x3. No changes.
  2. In HKLM>System>CurrentControlSet>Services>VSS>Diag I gave network service full control where it previously only had "Special Permission". No changes.

  3. I followed KB2009272 to manually try to fix system writer.

These are all of the things I have tried. What else should I look at to resolve this issue?

It may be important to note that I run Mozy Pro on this server and that was known in the past to use VSS for copying operations and it occasionally threw an error. However since an update last year those error event log entries have stopped.

edit: also tried to run kb2182466 because it dealt with the exact error code I was getting. The hotfix said I was not applicable.

I found a note about adding a Dword value called AllowSSBToAnyVolume to HKLM>System>CurrentControlSet>Services>WBengine>SystemStatebackup and I did this but no changes.

In order to ensure no other shadow copy data was present I got a fresh external hdd out of the box and formatted it to try a backup on. My previous attempts were with a drive already loaded with backup data. The results were the same on the new drive however.

share|improve this question
    
Have you ever found a solution to this? –  Volodymyr Sep 30 '13 at 12:43
    
No I haven't. I set up a scheduled acronis backup of the server as my safety net until I get more time to look at the issue. It's likely that we will re-purpose the server and when I rebuild it then it will get fixed. Not exactly how I wanted it to go.. –  TWood Oct 10 '13 at 19:09
    
The systemstate backup may fail due to large number of files and subfolders in C:\Windows\Microsoft.Net folder. Check for the number of files/subfolders there. This is known issue with VSS System writer which cannot process more than 10k+ subfolders. See here - blogs.msdn.com/b/ntdebugging/archive/2013/08/27/…. I also recommend to look into this article, which describes advanced troubleshooting techniques with procmon - blogs.msdn.com/b/ntdebugging/archive/2013/08/27/…. –  Volodymyr Oct 16 '13 at 8:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.