Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have a monitoring server with nagios,cacti and nedi on Debian Squeeze. when i try to install syslog-ng via apt-get i get the errors see below. i think that there is a problem with the sym-links in rc. but i don't know how to troubleshoot this problem.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  libdbd-mysql libdbd-pgsql libdbd-sqlite3
The following NEW packages will be installed:
  syslog-ng
0 upgraded, 1 newly installed, 0 to remove and 109 not upgraded.
Need to get 0 B/350 kB of archives.
After this operation, 705 kB of additional disk space will be used.
Selecting previously deselected package syslog-ng.
(Reading database ... 39405 files and directories currently installed.)
Unpacking syslog-ng (from .../syslog-ng_3.1.3-3_amd64.deb) ...
Processing triggers for man-db ...
Setting up syslog-ng (3.1.3-3) ...
insserv: warning: script 'K02networker' missing LSB tags and overrides
insserv: warning: script 'S99nagios' missing LSB tags and overrides
insserv: warning: script 'nagios' missing LSB tags and overrides
insserv: warning: script 'networker' missing LSB tags and overrides
insserv: Starting nagios depends on stop-bootlogd-single and therefore on system facility `$all' which can not be true!
.
.
.
insserv: Max recursions depth 99 reached
insserv: Starting nagios depends on stop-bootlogd-single and therefore on system facility `$all' which can not be true!
.
.
.
Stopping system logging: syslog-ng seems to be stopped already
Starting system logging: syslog-ng.
share|improve this question
    
How did you install nagios, exactly? The debian-packaged nagios has LSB tags in the init scripts... –  Keith Oct 10 '12 at 3:40

1 Answer 1

up vote 1 down vote accepted

Those warnings that LSB tags are missing, it means that in service script /etc/init.d/service_name is missing something like this:

### BEGIN INIT INFO
# Provides:          scriptname
# Required-Start:    $remote_fs $syslog
# Required-Stop:     $remote_fs $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Start daemon at boot time
# Description:       Enable service provided by daemon.
### END INIT INFO

Simple workaround is to remove insserv (which replaced update-rc.d in Debian 6.0):

apt-get remove insserv

Or probably better solution is to add those missing tags in all needed scripts.

Here is detailed description of LSB tags on debian wiki: LSBInitScripts
On this page is nicely described what is LSB: Init scripts based on LSB Init Standard

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.