Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've successfully installed vtiger and asterisk on Ubuntu, and I managed to configure them such that I get an incoming and an outgoing popup in vtiger. The problem is that when I click on an extension in vtiger to call another soft phone using SIP it shows me the outgoing popup saying Pick up the extensions receiver to dial the number. However my soft phone doesn't ring or allow me to pick up the receiver.

I'm not sure what the problem is. When another soft phone calls my extension and I pick it up then I do get the incoming popup in vtiger. The problem is only with outgoing calls. I get the popup but I can't make the call. The most annoying part is that I don't get any error logs in my asterisk cli terminal or anywhere else I can think of. Any help will be greatly appreciated.

share|improve this question

2 Answers 2

up vote 1 down vote accepted
+50

Set your Asterisk Extension in your vtiger User Preferences. See the vtiger wiki for complete configuration instructions.

share|improve this answer
    
I did that but the call isn't being forwarded to my extension. –  Aadit M Shah Sep 24 '12 at 13:50

I would try to have it append a # to the end of the number when dialing a local extension. So for instance if your extension is 1234 have the system dial 1234#.

share|improve this answer
    
I tried to do so to no avail. –  Aadit M Shah Sep 24 '12 at 14:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.