Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am configuring a Linux Server with ACL[Access Control Lists]. It is not allowing me to perform setfacl operation on one of the directoriy /xfiles. I am able to perform the setfacl on other directories as /tmp /op/applocal/.

I am getting the error as :

root@asifdl01devv # setfacl -m   user:eqtrd:rw-,user:feedmgr:r--,user::---,group::r--,mask:rw-,other:--- /xfiles/change1/testfile
setfacl: /xfiles/change1/testfile: Operation not supported

I have defined my /etc/fstab as

/dev/ROOTVG/rootlv      /                       ext3    defaults        1 1
/dev/ROOTVG/varlv       /var                    ext3    defaults        1 2
/dev/ROOTVG/optlv       /opt                    ext3    defaults        1 2
/dev/ROOTVG/crashlv     /var/crash              ext3    defaults        1 2
/dev/ROOTVG/tmplv       /tmp                    ext3    defaults        1 2
LABEL=/boot             /boot                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/ROOTVG/swaplv      swap                    swap    defaults        0 0
/dev/APPVG/home      /home            ext3    defaults        1 2
/dev/APPVG/archives      /archives            ext3    defaults        1 2
/dev/APPVG/test      /test            ext3    defaults        1 2
/dev/APPVG/oracle      /opt/oracle            ext3    defaults        1 2
/dev/APPVG/ifeeds      /xfiles            ext3    defaults        1 2

I have a solaris server where the vfstab is defined as

cat vfstab

#device         device          mount           FS      fsck    mount   mount
#to mount       to fsck         point           type    pass    at boot options
#
fd      -       /dev/fd fd      -       no      -
/proc   -       /proc   proc    -       no      -
/dev/vx/dsk/bootdg/swapvol      -       -       swap    -       no      -
swap    -       /tmp    tmpfs   -       yes     size=1024m
/dev/vx/dsk/bootdg/rootvol      /dev/vx/rdsk/bootdg/rootvol     /       ufs     1       no      logging
/dev/vx/dsk/bootdg/var  /dev/vx/rdsk/bootdg/var /var    ufs     1       no      logging
/dev/vx/dsk/bootdg/home /dev/vx/rdsk/bootdg/home        /home   ufs     2       yes     logging
/dev/vx/dsk/APP/test        /dev/vx/rdsk/APP/test       /test     vxfs   3       yes     -
/dev/vx/dsk/APP/archives        /dev/vx/rdsk/APP/archives       /archives     vxfs   3       yes     -
/dev/vx/dsk/APP/oracle        /dev/vx/rdsk/APP/oracle       /opt/oracle     vxfs   3       yes     -
/dev/vx/dsk/APP/xfiles    /dev/vx/rdsk/APP/xfiles   /xfiles vxfs   3       yes     -

I am not able to find out the issue. Any help would be appreciated.

share|improve this question

1 Answer 1

You need to enable acls on the mount point. Either remount with the acl option or reboot with the acl option in the fstab.

You need to first check if your kernel supports the acl option - otherwise, the mount may fail.

To check if acl was compiled into the kernel

cat /boot/config-`uname -r` | grep _ACL

The 'expected' output should be something like this ..

CONFIG_EXT2_FS_POSIX_ACL=y
CONFIG_EXT3_FS_POSIX_ACL=y
CONFIG_EXT4_FS_POSIX_ACL=y
CONFIG_FS_POSIX_ACL=y
CONFIG_XFS_POSIX_ACL=y
CONFIG_NFS_V3_ACL=y
CONFIG_NFSD_V3_ACL=y
CONFIG_NFS_ACL_SUPPORT=m

To remount without reboot

mount -o remount,acl /xfiles

To mount with acl with a reboot/persistent

/dev/APPVG/ifeeds      /xfiles            ext3    defaults,acl        1 2
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.