Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two NAS (Seagate Black Armors) connected to our network through iSCSI to a Dell Optiplex 760 running 32-bit Windows 7 and Windows iSCSI Initiator.

For some unknown reason, within the last week or so, both report as inaccessible and/or corrupt (that is the error message generated when I attempt to open the on the iSCSI computer). However, connecting to either of them via direct IP works fine.

I've tried Error checking but received "The disk check could not be performed because Windows could not access the disk." I've tried System Recover to a date almost two weeks back thinking Windows update may have caused the issue but there is no change.

I'm including screenshots in hopes of solving the issue.

iSCSI configuration on NAS NAS share page NAS volume configuration


share|improve this question
When you say direct via IP, are you talking about accessing the share via SMB? – longneck Sep 19 '12 at 16:23
That is correct. – Hammer1 Sep 19 '12 at 19:45
From what I'm reading about BlackArmor NAS, iSCSI volumes are not accessible via SMB. Did you mention that to prove basic connectivity, or are you able to access your iSCSI volumes via SMB, too? – longneck Sep 19 '12 at 20:50
I've set them up to be accessed by users mapping a network drive to the IP addresses (Mac's) or names (Windows) of the NAS's. Each user has separate login and password I created for them. – Hammer1 Sep 20 '12 at 13:46

Sounds alot like the dns for the iscsi device is now expired. That explains the ip only access.

Try putting the names in the c:\windows\system32\drivers\etc\hosts file. Format is:

name ip, like:


Try to ping by name, it should then start working

share|improve this answer

A volume can be shared via iSCSI, or SMB. Both not both. Those access methods are mutually exclusive.

See Using same drive for iSCSI and SMB share under FreeNAS

share|improve this answer
Interestingly this was working via both until a couple of weeks ago. The reason for iSCSI is for backng the NAS to an off-site IBM Tivoli TSM system on our campus. It requires an OS as a pass through. All of a sudden the iSCSI computer says it can't access the P: drive, which is the NAS I was backing up. While the back up was working users were also accessing the NAS via SMB just fine. – Hammer1 Sep 20 '12 at 15:55
please post screen shots of the share, iscsi, and volume configuration screens of your NAS. to do this, you will need to modify your original question. – longneck Sep 20 '12 at 16:28
I've add the configuration screens and modified the original question. – Hammer1 Sep 25 '12 at 13:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.