Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason my Fedora is not saving changes made to my iptables.

iptables -I INPUT -p tcp --dport 80 -j ACCEPT
iptables -I INPUT -p tcp --dport 443 -j ACCEPT
service iptables status
service iptables restart

Redirecting to /bin/systemctl  status iptables.service

Then when starting, my changes are not there anymore.

Also tried saving:

[root@VTM01 ~]# service iptables save
Redirecting to /bin/systemctl  save iptables.service
Unknown operation save
share|improve this question
up vote 5 down vote accepted

Under previous versions of Fedora, it required service iptables save.

Looks like it has been changed to /usr/libexec/iptables.init save.

3.8.3. Saving IPTables Rules

share|improve this answer
Check out the post, I tried this earlier but did not include it because I thought I was imagining the command. – Louis W Sep 19 '12 at 20:49
You're right! Looks like they changed it under Fedora 17. I'll edit my post. – Aaron Copley Sep 19 '12 at 20:51

It have change once again.

sudo service iptables save

does not works anymore you have to edit the config file to does that.

sudo vim /etc/sysconfig/iptables-config
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.