Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to upgrade PHP 5.2.13 to 5.3.16 in Solaris 9 SPARC box. I have installed many extensions in the current version (5.2.13). The installation of PHP 5.2.13 was through binaries and not through source. The extnesions were installed through source via configure, make, make install commands.

While upgrading, is it enough if I copy over the .so files across to extensions directory or configure them afresh?

Any info is well appreciated.

Thank you SKB

share|improve this question
1  
Hard to say. Probably not, but try it, and see if it works. –  Steve Kehlet Sep 20 '12 at 22:55
    
I am installing PHP 5.3.x from source on the SOlaris 9 box now. After the configure command, when I do "make", it fails with the following library error. Any clue? grep: can't open /usr/local/lib/libfontconfig.la /usr/local/bin/sed: can't read /usr/local/lib/libfontconfig.la: No such file or directory libtool: link: /usr/local/lib/libfontconfig.la' is not a valid libtool archive *** Error code 1 make: Fatal error: Command failed for target libphp5.la' –  SKB Sep 24 '12 at 4:45
    
I would look into rebuilding fontconfig to see if you can figure out how to get it to install those .la files. Run ./configure --help to see all the options, maybe try things like --enable-shared. I'm not an expert on that but I believe those .la files are to help when building other packages (like PHP). –  Steve Kehlet Sep 24 '12 at 17:26
    
fontconfig seems to be already there in that system. pkginfo shows the library, documentation as installed. Still if I got to install, where can I get the pkgs from,any clue? –  SKB Sep 25 '12 at 1:15
    
Found fontconfig and installed the same. The configure, make ran fine but make install throws the following error... Can someone advise?Installing PHP SAPI module: apache2handler /usr/local/apache2/build/instdso.sh SH_LIBTOOL='/usr/local/apache2/build/libtool' libphp5.la /usr/local/apache2/modules /usr/local/apr/build-1/libtool --mode=install cp libphp5.la /usr/local/apache2/modules/ /usr/local/apache2/build/instdso.sh: /usr/local/apr/build-1/libtool: not found apxs:Error: Command failed with rc=65536 make: Fatal error: Command failed for target `install-sapi' –  SKB Sep 26 '12 at 2:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.