Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have shared folder with an app on win 2008 server. After successful maping of this shared folder from other PC in local network can be open only text files and images. App (.exe) cannot be run. (App works fine, is runing on other server win 2003. Win 2008 is new instalation on new machine.)

Is there extra setting to allow it?

  • Loged as administrator - each machine
  • Granted all permission to account in sharing properties (read, write etc.)

Simplified version of question:

win2003 server, active directory, main Administrator (administrators - all permissions. I am only the who is managing server.)

  • I create shared foleder (with app to be run.)
  • Folder is maped as network drive (ex: \server\folder)
  • Works fine for all network members except server machine iself. Those will sucessfully map folder, will open it, list it, allow edit text files or view images, but doesn't allow run anything becouse of 'no permission'

I trust that answer for this simplified version will answer me the question up.

share|improve this question
2  
you should clarify a question, are you logged as and administrator on the PC machine, or are you logged on the share with the administrator account of the win 2008 server. With what account do you access the share on the windows 2003 server and with what on the PC. Also are you working with only local accounts or is this a windows domain environment and you're working with domain accounts. Also what exactly do you mean by not being able to open .exe, do you get some error message when you trying to open, or maybe app starts and crashes with an memory exception message (i had that problem) –  Alen Sep 20 '12 at 9:49
2  
I imagine this is something to do with security with Trusted Sites in IE. –  boburob Sep 20 '12 at 10:31

1 Answer 1

up vote 1 down vote accepted

Add your servers address in the users Control Panel -> Internet Options -> Security -> Trusted sites -> Sites. If you server name is "AppServer" then add "\AppServer" in the trusted list. You should have have no problem running it then.

If this solves your issue then you might consider configuring this settings via GroupPolicy it will faster and effective.

Hope this will solve your problem.

Update:

I'm sorry for the late replay. First add a new Group Policy Object (or you may modify another one). Then in that group policy go to Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Internet Control Panel -> Security Page -> Site To Zone Assignment List -> Show Then add you server as \Server\ and Value as 2 (Trusted Site Zone)

If you face any problem plz let me know. PS: i tried to add it as a comment but it gave error something like can be editied within 5 mins or something.

share|improve this answer
    
Thank you. Could you be more concrete please about setting via Group Policy? –  Jirka Kopřiva Sep 25 '12 at 10:09
    
I'm sorry for the late replay. –  rrahman_bd Oct 2 '12 at 4:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.