Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just migrated to Google Apps and it works great, except one little naging thing.

Previously we used CPanel (with Roundcube) to send our mail to each other in the company. But after the switch we try to always use Gmail. But due to different reasons (som unanswered mail etc.) we still have to send some mail via Roundcube. However, if we do this, the mail seems to never leaves the server – it seems like if it checks if the adress belongs to the same domain, the mail never leaves the server but sends it to Roundcube instead of Gmail.


User sends from Roundcube to a @company adress -> email ends up at Roundcube.
User sends from elsewhere to a @company adress -> email ends up at Gmail.

Any ideas on how to fix this? To force outgoing mail to always "leave" the server?

share|improve this question
up vote 4 down vote accepted

You've pretty much got it with your last sentence: You need to configure the MTA on your CPanel server so it doesn't consider your @company address to be a destination for which it handles mail, and instead does a DNS lookup for the mail route.

share|improve this answer
Thank you very much for your answer – however, I've never come across the word "TMA" before, and can't find much related to CPanel or on how I can perform the DNS Lookup for the mail route. Any ideas on where to start? – Marcus Sep 20 '12 at 14:02
MTA is mail transport agent, it's an SMTP server which in this case seems to thing that mail to @company should end up on your server. Which your SMTP settings in CPanel and Roundcube to see which server they're using and then reconfigure it if you can, or ask whoever runs it to reconfigure it. Alternatively you could bypass it by changing the SMTP (outgoing mail) settings to talk to Google's SMTP direct. – James Yale Sep 20 '12 at 14:27
Just found this link which seems to deal with how to configure your MTA in CPanel:… – James Yale Sep 20 '12 at 14:29
Okay, but if I were to use Gmail as an outgoing SMTP server, then we would have some problems – because they limit each account to 500 outgoing mails per day. And some of our accounts can send up to 30 000 (automated mails) per day... So we would really like to keep the ability to send bulk mail through our own servers, just not to another @company-adress. – Marcus Sep 21 '12 at 6:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.