Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm mounting s3 using s3fs with the following command:

sudo /usr/local/bin/s3fs -o use_cache=/tmp,uid=1000,gid=1000,allow_other svn.domain.com /svn

Allow_other is confirmed to be working along with cache. However, no variation/different placement of the uid/gid's is having any affect in the meta data on S3. Both the uid and gid come up as '0' in S3. I have created a user called svn with uid of 1000 to see if that would fix the problem. No luck.

share|improve this question
s3fs is not something you want to be using for anything critical, especially a source code repo. If you're running on EC2, just attach another EBS vol. If running elsewhere, well, pony up for more storage. –  EEAA Sep 21 '12 at 3:30
We're using it as a backup. It's being used. I need to figure out why a 'common' flag option isn't working. –  Publiccert Sep 21 '12 at 3:31
In that case, I'd highly suggest using duplicity. It will be much more reliable in the long run than the hack that s3fs is. –  EEAA Sep 21 '12 at 3:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.