Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm attempting to set up Cacti to monitor a router's interfaces, and I'm having trouble getting the graph templates to show the information that I'd like.

Our interface configuration looks like this:

 interface GigabitEthernet3/6
  description WalljackNumber # Server info 
  no ip address
  no shutdown
  switchport
  switchport access vlan 116
  switchport mode access
  ip dhcp snooping trust
  spanning-tree portfast

The "Server Info" string is really just the machine name, and a short relevant description, such as "PolarSprings vmnic2". The important part appears to be that it follows the hashmark.

When I run snmpwalk, I get the proper output:

 IF-MIB::ifAlias.230 = STRING: WalljackNumber # Server info

But in Cacti, when I go into the graph templates and set the title to this:

 |host_description| - Traffic - |query_ifName| (|query_ifAlias|)

All that shows up in the graph is:

switchname - Traffic - Gi3/6 (WalljackNumber #) 

Which strikes me as a little weird. What I suppose MAY be happening is that somewhere in the cacti stream, it's interpreting # as being a comment and stripping everything after, but I'm not sure.

I was hoping someone could tell me that this was a known documented behavior, or that I could change it in a setting that I wasn't aware of. The alternative answer is to change the delimiter from # to something else, but I've got over a thousand lit switchports on an old college infrastructure, and I'm not sure what else might be relying on them.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

@Complex on twitter found it for me.

The issue is that there's a maximum field length setting that was getting in the way.

As found at http://www.cacti.net/downloads/docs/html/faq.html#AEN2524, you go to Console, then Configuration/Settings, and alter Maximum Field Length to a more reasonable number, and it starts working shortly.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.