Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Recently we upgrade our web server to windows server 2012 with IIS8.

We have this issue when users try to connect the asp.net state service to this web server remotely.

It always popup

Unable to make the session state request to the session state server. Please ensure that the ASP.NET State service is started and that the client and server ports are the same. If the server is on a remote machine, please ensure that it accepts remote requests by checking the value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aspnet_state\Parameters\AllowRemoteConnection. If the server is on the local machine, and if the before mentioned registry value does not exist or is set to 0, then the state server connection string must use either 'localhost' or '127.0.0.1' as the server name.

In IIS7 / 7.5 we use the same way and it works fine. As long as the state service is running and firewall is set properly, we don't have any problem. However, in IIS8 it doesn't work. (We even turn off firewall to test it)

Thanks for helping.

share|improve this question

migrated from stackoverflow.com Sep 21 '12 at 15:32

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 2 down vote accepted

Found a way to fix it.

  1. Run Regedit

  2. find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aspnet_state\Parameters\AllowRemoteConnection

  3. Set it to 1 instead of 0.

  4. Restart asp.net state service.

It is so weird, I can't find anywhere to set this through interface. And I don't think I need to do this in IIS7 / 7.5.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.