Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently configured accelerator and fastcgi with apache using: http://secure-ubuntu-server.blogspot.com/2009/07/howto-performance-tuning-of-lamp-and.html

Now my Apache never starts.

Logs shows:

Mon Jul 20 16:12:24 2009] [notice] ModSecurity for Apache/2.5.6 (http://www.modsecurity.org/) configured.
[Mon Jul 20 16:12:25 2009] [notice] FastCGI: process manager initialized (pid 10919)
[Mon Jul 20 16:12:25 2009] [alert] FastCGI: read() from pipe failed (0)
[Mon Jul 20 16:12:25 2009] [alert] FastCGI: the PM is shutting down, Apache seems to have disappeared - bye
share|improve this question
add comment

4 Answers

What's the exact version of PHP you're using? eAccelerator isn't compatible with PHP 5.3 - honestly, I'd strongly recommend APC or XCache above eAccelerator.

share|improve this answer
add comment

Try running an Apache instance directly from the command line (i.e. run /usr/sbin/apache2 or whatever the HTTPD executable is) to see if you get any more feedback (like, say, Segmentation fault).

share|improve this answer
    
nope, nothing is printed on command line. All i get is messages in error log. I have also posted in that blog for support request. –  Shoaibi Jul 20 '09 at 18:15
    
Its the problem with eaccelerator i think because as soon as i comment "extension=" in php.ini, apache starts working... –  Shoaibi Jul 21 '09 at 4:27
    
What happens when you uncomment the eaccelerator extension and run php -v from command line? –  chaos Jul 22 '09 at 15:54
add comment

I can't comment, so I'll post here.

Probably, php is causing a segmentation fault and hence apache is dying. If you're using php-cgi in FcgidWrapper or something else, however you configured php with fastcgi, try running that thing directly from the command line.

For instance, /usr/bin/php-cgi.

If you have configured it using the Action directive, ensure that the wrapper has the executable bit set.

share|improve this answer
add comment

try running the apache binary from the shell with strace:

strace -f /usr/sbin/apache2 > /tmp/outfile

or whatever your binary is. After that check the file with less or tail to check the last entries that happend before the apache dies (shortly before the error message is written in the log).

less /tmp/outfile

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.