Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Supermicro X9DRD-IF motherboard with IPMI onboard. I'm completely losing network (both IPMI and OS) after adding VLAN support in OS network configuration. Network cable is connected into LAN1 port. IPMI is configured as shared. IPMI VLAN is not set. IPMI firmware was updated to latest version. Network comes with VLAN 171 untagged (XX.XX.XX.0/26) and VLAN 169 (YY.YY.YY.128/27) tagged. Switch is HP Procurve 2824 J4903A.

My IPMI network config in BIOS:

Configuration Address source: [Static]
Station IP address XX.XX.XX.003
Subnet mask 255.255.255.192
Station MAC address 00-25-90-4e-73-7b (not editable)
Gateway IP address XX.XX.XX.001

Config with these two files is working fine:

cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE="br0"
BOOTPROTO="static"
BROADCAST="XX.XX.XX.63"
IPADDR="XX.XX.XX.4"
NETMASK="255.255.255.192"
NETWORK="XX.XX.XX.0"
GATEWAY="XX.XX.XX.1"
ONBOOT="yes"
TYPE="Bridge"

cat /etc/sysconfig/network-scripts/ifcfg-eth0:
DEVICE="eth0"
HWADDR="00:25:90:4E:9A:E4"
ONBOOT="yes"
BRIDGE="br0"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"

But just after I add VLAN config file, and restart network, I lose connection. No ping both on IPMI and OS IPs. This is my VLAN config:

cat /etc/sysconfig/network-scripts/ifcfg-eth0.169:
VLAN="yes"
DEVICE="eth0.169"
HWADDR="00:25:90:4E:9A:E4"
IPV6INIT="yes"
IPV6_AUTOCONF="yes"
ONBOOT="yes"
BRIDGE="br0"
BOOTPROTO="none"
TYPE="Ethernet"

Also I tried to add driver option as suggested here and here

options e1000e CrcStripping=0

in /etc/modprobe.d/e1000e.conf, but it didn't help.

By the way, I have similar VLAN config working fine on another server with older X8STi-F and CentOS 5.8, but on new server I have no more ideas what I have to do.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Do you have any option to use a dedicated IMPI port? Shared is not a good option if you plan to use OS-level VLAN configurations. You typically have to have the eth0/first interface and the IPMI on the same VLAN...

See: How does IPMI sideband share the ethernet port with the host?

share|improve this answer
    
They are on the same VLAN. But it works only until additional VLAN configured. I have an option to use a dedicated port, but it will increase collocation cost for me. If I'll not find the answer or workaround, then I'll have to buy it. –  Evolver Sep 23 '12 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.