Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have two Server 2008 R2 servers running DFS-R (named dfs01 and dfs02) in a 2008 R2 Domain.

Today I found the files in server dfs01 can not be replicated to dfs02. So I used the command

dfsrdiag backlog /rgname:<group> /rfname:<folder> /sendingmember:dfs01/receivingmember:dfs02

to check the backlog. After executing the command, I get the following error:

Failed to execute GetVersionVector Method. Err: -2147217406 <0x80041002> operation Failed.

How can I resolve this?

share|improve this question
how about more information? What does google say for that error? Anything in event logs, including the DFSR one? Do you get the same error on the other AD box? The more you list things you've tried the more likely you'll get help here. – Bret Fisher Sep 23 '12 at 15:14
Thanks! After checking again, if i create the Replication group under other drivers(eg:e driver),the replication will work. But if i create the replication group under same driver(current in D driver) or delete and re-create the replication group in the same drivers, the replication will not work and come out the same error? Is it the jet database under system volume information corrupt? – e0594cn Sep 24 '12 at 6:22
After running the replication folder health report, the report will indicate Cannot access the local WMI repository. – e0594cn Sep 24 '12 at 7:35
up vote 6 down vote accepted

This happens after you install hotfix 2663685

It changes the behaviour after a dirty DFSR shutdown so that there is no longer an automatic restart, instead it stays down allowing you to do whatever backups you may need to do, then you run a WMI command as per the article to restart it.

Word of warning - applying this hotfix on a cluster means it effectively isn't highly avaialble as a failover will leave DFSR down on the node taking over. You can adjust this by a registry setting. Personally, I'm about to undo this hotfix across our estate as it's more trouble than it's worth, DFSR falls over and doesn't come back online til we arrive in on Monday, and the backlogs just grow and grow

share|improve this answer
Hello, May I ask how do you get the GUID for the upstream server, according to the KB link? – Jake Aug 7 '13 at 3:26
@jake - easiest thing to do is go to the DFS server and go to the event log, and look for event code 2213 under Applications and Services Log > DFS Replication - you will find the exact command you need to run logged in there. – Mark Henderson Nov 6 '13 at 21:36

The easiest way to get this up and running again is to go to your Event Viewer, and go to Applications and Services Log > DFS Replication. Look for the event 2213:

enter image description here

The exact command you need to run is in there.

Additionally, to revert DFS-R back to its original settings, run this:

wmic /namespace:\\root\microsoftdfs path dfsrmachineconfig set StopReplicationOnAutoRecovery=FALSE
share|improve this answer

I just ran into this similar issue but hotfix 2663685 was not my problem. In my case dfsrdiag would work for some of my replicated folders but not all of them. The replicated folders were distributed over different drives.

Long story short is that DFSR would not process the replicated folder because of a corrupted database. You can verify the drive is missing with this command. It should list all the drives you have DFSR Folders on.

wmic /namespace:\\root\microsoftdfs path dfsrvolumeinfo get volumepath, VolumeGuid

Mine was missing one of the DFSR Volumes. It will probably still be listed in the config so you can check with this command if your not sure if any are missing.

wmic /namespace:\\root\microsoftdfs\ path dfsrVolumeConfig get *

Also check C:\Windows\debug\dfsr*.log for other messages about the drive not being ready or not being able to read the serial numbers.

To resolve it I had to stop DFSR and delete/rename the database. It then started to sync and after a while of rebuilding the commands finally worked.

  1. Open a cmd prompt as system(I hate to modify permissions of "system volume information" doing this you can avoid that. Google how to do it.)
  2. Go to the drive with the corrupt database .ie "D:"
  3. cd "system volume information"
  4. cd "DFSR"
  5. rename Config\Volume_.XML Config\Volume_.OLD
  6. rename Config\Replica_.XML Config\Replica_.OLD
  7. rename database_ database__OLD
  8. net start dfsr
  9. dfsrdiag pollad

Also DFSR logs are way to detailed and limited to 1000 log files by default. Please change the log level to something sane because once you hit 1000 DFSR just stops.

wmic /namespace:\\root\microsoftdfs path dfsrmachineconfig set debuglogseverity=3

share|improve this answer

Since it does work on a different volume then D, I would assume it's related to the D volume, and reformat that volume (or just delete and recreate volume) or permanently move the replica to a different volume. If there was truly something wrong with DFSR itself, it wouldn't work regardless of the replica or volume.

share|improve this answer
but there are too many shared folder under this volume, it will take too many time to move the data. I just want to find out the root cause. – e0594cn Sep 25 '12 at 3:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.