Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have converted my old Dell Latitude D410 laptop to a server for tinkering. It is running an updated Debian Squeeze (6) with a Xen enabled kernel (I want to toy with virtual machines later on). I am running it 'headless' via an ethernet connection.

I am struggling to enable Wake On Lan for the box. I have enabled the setting in the BIOS, and it works nicely, but only for the first time after the power cord is plugged in. Here is my test:

  1. Plug in power cord, don't boot yet
  2. Send magic Wake On Lan packet from test machine (Ubuntu) using the wakeonlan program
  3. Server expected to start (does every time)
  4. Once server has booted, log in via ssh and shut it down via the operating system
  5. After shutdown, wake server up via WOL again (fails every time)

Some observations:

  • Right after step 1 I can see the integrated NIC has a light on. I deduce this means the NIC gets adequate power and that the ethernet cable is connected to my switch. This light is not on after step 4 (the shutdown stage). The light becomes back on after I disconnect and reconnect the power cord, after which WOL works as well.
  • After step 4 I can verify that wake on lan is enabled via the ethtool program (repeatable each time)
  • This blog post suggested the problem may lay in the fact the motherboard might not be giving adequate power to the NIC after shutdown, so I copied an acpitool script that supposedly should signal the system to give the needed power to the card when shut down. Obviously it did not fix my issue. I have included the relevant power settings in the paste below.
  • I have tried different combinations of parameters of shutdown (the program) options, as well as the poweroff program. I even tried "telinit 0", which I figured would do the most direct boot via software.
  • If I keep the laptop's power button pressed down and do a hard boot this way, the light on the ethernet port stays lit and a WOL is possible.
  • I copied a bunch of hopefully useful information in this paste
  • I have tried this with the laptop battery connected and without it. I get the same result.
  • Promptly pressing the power button causes the system to shut down with the message "The system is going down for system halt NOW!", and WOL is still unsuccessful.
share|improve this question

closed as off topic by SvW, rnxrx, Ward, Michael Hampton, Iain Sep 25 '12 at 22:15

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I think it's in the bios settings. Can you take some pics, maybe with your mobile, and put them onto the web somewhere? –  ott-- Sep 23 '12 at 20:56
    
Also it's a good idea to use the latest BIOS version, because after all it can be a bios bug. –  golja Sep 24 '12 at 0:23
    
I checked if a newer BIOS was available. Looks like one isn't, and besides Dell only offers an installer for Windows XP, which I don't have. Too bad. –  sp3ctum Sep 24 '12 at 17:56

1 Answer 1

up vote 0 down vote accepted

I have solved the problem myself by accident. I don't know exactly what happened.

I know this "answer" isn't very helpful. We've all been here: something starts working and we don't want to break it to try to determine what exactly fixed it.

Here's a list of things I was doing to possibly help others in the same situation.

  • enable Debian testing repos in /etc/apt/sources.list
  • apt-get update, apt-get upgrade
  • apt-get install hibernate

I started to experiment with hibernation as an option, though it did not work either.

  • restart the system
  • shutdown the system. Observed the NIC link light to be on.
  • Wake on Lan works for sequent boot / shutdown cycles now.

Things like this make me feel glad and stupid.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.