Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

According to my server host, something called Tomcat is hogging all my resources and slowing down the server. As far as I'm aware I'm not using it as the only thing running on the server is Plesk and a few Wordpress installations.

I'm a real dummy at using SSH, I can navigate to folders, change permissions and that's about it. Could somebody explain to me as if I'm a 5 year old how to disable TomCat (and also how to stop it re-enabling on startup)?

Thanks!

share|improve this question
2  
get the skills or get skilled people to do it. But /etc/init.d/tomcat stop or /etc/init.d/tomcat6 stop works on most distro –  coincoin Sep 23 '12 at 22:56
    
Since this is a beginner question it would probably get more attention on superuser. Flagged for migration. –  Starfish Sep 24 '12 at 0:01
5  
@Starfish - it may be beginner, but that's no reason to send it to SU. Nowhere does this really fit into SU's scope or FAQ. –  Mark Henderson Sep 24 '12 at 0:04

1 Answer 1

Tomcat is a web application server. The easiest way to find out if it is running is to do a ps -ef | grep -i catalina command. This will show up any process with catalina(tomcat) in it. If you see a line returned other than a result with "grep -i catalina" in it, it is running.

If you are root, you should be able to stop the service by either running /etc/init.d/tomcat stop or /etc/init.d/tomcat as stated in @Eric DANNIELOU comment. Another method is to goto the catalina home area, shown in the line returned by the prior ps -ef | grep -i catalina command. It is the directory after "-Dcatalina.home=". Navigate to that directory and then into the bin directory inside of it. You should see a catalina.sh file in there. Run ./catalina.sh stop and that will stop tomcat.

As for if it is set to startup, most distros(I believe all but not sure) have /etc/rcX.d directories, where X is the run level. If this is a server it is likely booting into run level 3. Go into /etc/rc3.d and see if there is a SXXtomcat or SXXtomcat6 file, where XX is a number. If it exists there, you should be able to delete that file to prevent it from starting up. If this is a RedHat server it may be easier to use chkconfig command. You can do a chkconfig --list | grep tomcat and it will lists the run level and on or off for that run level. Look at chkconfig @ linuxcommand.org for more help how to disable a service.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.