Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a weird issue with a vBulletin forum, on a 2х Xeon E5645 w/ 16GB RAM CentOS 6.3 x86_64 web server with cPanel and LiteSpeed; It takes too long to start loading...

When I tested it with webpagetest.org I saw that for every request there's a 3 second "Initial connection" delay, which I don't know why is happening. Here's a screenshot: enter image description here

CPU Load is between 0.03 and 0.05, I've got several GB of free RAM, practical no I/O activity, and this delay can occur even with only one visitor on the forum.

Where do you suggest I start searching? What could be the reason for this kind of delay? I don't think it's the webserver, or the forum because there's another website on the server (total 2 sites) which is WordPress based, and has exactly the same issue with the 3 second initial connection delay. I believe it's OS related, but need a clue on where to start looking.

share|improve this question
    
Latency/network congestion? Where are you running the test from/to (geographically) –  sonassi Sep 24 '12 at 7:55
    
I don't think so, since pinging the server is at around 60ms. Same delay is shown at tools.pingdom.com too, whether I run the test from Amsterdam or Dallas. It must be something OS related I guess. –  George Tasioulis Sep 24 '12 at 9:37
    
What Linux distro and version are you running? –  Starfish Sep 26 '12 at 4:13
    
@Starfish CentOS 6.3 x86_64 –  George Tasioulis Sep 26 '12 at 9:04
    
Did the dns lookup solve the problem? –  Ed King Oct 1 '12 at 15:46
add comment

3 Answers

up vote 6 down vote accepted
+50

Check reverse DNS -- the logging on the web server may be trying to lookup the name of the client, and timing out.

Test it by putting a known IP address in the /etc/hosts table, make sure you can ping by name (lookup working -- if not check the /etc/resolv.conf).

share|improve this answer
add comment

This makes me think about MTU issues. Ping will work fine because it sends shorts packets, but what happens when you ping with larger packets ? And you did disable jumbo frames, did you ?

ping -s 1500 your_server

Either that, or a firewall in the middle does not like your initial TCP parameters or MTU, and/or block 'fragmentation needed' ICMP errors.

share|improve this answer
add comment

Try using: OpenDNS - Cloud Internet Security and DNS.

$ cat /etc/resolv.conf 
nameserver 208.67.222.222
nameserver 208.67.220.220
$ 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.