Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Referencing this page:

http://feedback.livereload.com/knowledgebase/articles/86280-if-you-edit-files-directly-on-your-server

It says you can remotely port forward the LiveReload specific port of 35729, using this command:

ssh -L 35729:127.0.0.1:35729 mylogin@myremoteserverIP

When I run the -v option, I get:

debug1: Local connections to LOCALHOST:35729 forwarded to remote address 127.0.0.1:35729  debug1: Local forwarding listening on ::1 port 35729.  
debug1: channel 0: new [port listener]  
debug1: Local forwarding listening on 127.0.0.1 port 35729.  
debug1: channel 1: new [port listener]  
debug1: channel 2: new [client-session]  
debug1: Entering interactive session.  
debug1: Sending environment.  
debug1: client_input_channel_req: channel 2 rtype keepalive@openssh.com reply 1  
debug1: Connection to port 35729 forwarding to 127.0.0.1 port 35729 requested.  
debug1: channel 3: new [direct-tcpip]  
channel 3: open failed: connect failed: Connection refused  
debug1: channel 3: free: direct-tcpip: listening port 35729 for 127.0.0.1 port 35729, connect from 127.0.0.1 port 63673, nchannels 4

I thought editing my /etc/services with this line, would work, but it doesn't:

livereload        35729/tcp              # livereload usage with guard-livereload

Every time I attempt to connect with the browser extension, I believe It's getting blocked by my server. What am I missing here? Do I need to edit /etc/services for this to work?

share|improve this question

1 Answer 1

Here we see the problem:

channel 3: open failed: connect failed: Connection refused

This means that nothing was listening on port 35729 on the remote host, or you have firewalled localhost (not very likely).

Try starting Guard and ensure that it is actually listening on that port.

share|improve this answer
    
@micheal-hampton On my myremoteserverIP, the system firewall is turned off. I know that LiveReload is hitting it, because my SSH tunnel will throw that error every time a change is made to my website (trigging LiveReload to make a connection through the SSH tunnel). Is it possible I'm not editing etc/services/ or making the system take the update to that file correctly on my Linux box? –  program247365 Sep 26 '12 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.