Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running IIS on port 80, I configured Apache on port 8080, while I am accessing my Apache server, I can't access without typing the port, such as:

http://mywebsite.co.in:8080/main

But i want to access like:

http://mywebsite.co.in/page

How do I hide or remove port in my url?

share|improve this question
add comment

1 Answer

You need to specify the port in your url because you are running your webserver (Apache) on a non-standard port. So, to eliminate this, you need to run Apache on port 80, which is the default http port, and what's assumed by the browser if no port is given.

So, your options are:

  1. Get a new server for Apache
  2. Move Apache to port 80, and move/delete IIS
  3. Put up with needing the port in the url
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.