Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can't seem to make Apache 2.4 compile straight from source the way I want it to. It insists on including a whole bunch of shared modules I do my best not to, all the while ignoring those I request to be compiled statically..

Here's my command:

./configure --enable-pie --prefix [dir] --enable-modules="unixd" --enable-mods-shared=none --with-included-apr

It seems to me --enable-mods-shared=none isn't a valid parameter, but it's the only thing I've found that seems close to explicitly disabling mod_so (which shouldn't even be needed).

I guess it's something quite evident, but I just fail miserably to sort it out.

Edit: Now wait a minute... what's that 2.2 in the configure doc url..

share|improve this question
add comment

1 Answer

So that was it:

  • configure changed a bit between 2.2 and 2.4 (it's --enable-mods-static now)
  • apachectl -M just dumps what it parses from httpd.conf, instead of my custom config. That's logical, but I thought apachectl did something a little more advanced that just that
  • enable-mods-shared=none is accepted and valid after all
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.