Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I compiled Phalcon using the instructions on the site, added extension = phalcon.so to the end of my php.ini file. I restarted the server but when I run print_r(get_loaded_extensions());

Phalcon isn't there.

I'm using nginx on Ubuntu, if that matters.

share|improve this question

migrated from stackoverflow.com Sep 25 '12 at 11:10

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 0 down vote accepted

Have you enabled the extension in your php.ini configuration?

extension = /usr/lib/php5/20090626/phalcon.so

That is I believe the path of where the extension will be compiled in a Ubuntu box.

Restart the server after that or in your case php_fpm :)

share|improve this answer
    
Thanks that worked. How did you know it would be compiled there? –  user1587033 Sep 22 '12 at 22:41
    
The key is that you are using Ubuntu which I am too. You can always see the path of where the extension is installed at the output of the compilation process. I believe it is when issuing sudo make install –  Nikolaos Dimopoulos Sep 22 '12 at 23:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.