Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Goodafternoon,

I am trying to update my pcre-6.6-6.el5_6.1.x86_64 package to pcre-8.31 following is my steps to do so:

Step

1: cd /etc/yum.repos.d

  1. Made repository utter-ramblings.repo in it.

  2. Populated utter-ramblings.repo file with

    [utter-ramblings]
    name=Utter Ramblings
    baseurl=http://www.jasonlitka.com/media/EL5/i386/
    gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka
    enabled=1
    gpgcheck=1
    
  3. Then following command:

    yum install pcre
    

I got installation process started successfully but with following errors

    Transaction Check Error:
    file /usr/share/man/man1/pcregrep.1.gz from install of pcre-8.13-1.jason.2.i386   conflicts with file from package pcre-6.6-6.el5_6.1.x86_64

file /usr/share/man/man1/pcretest.1.gz from install of pcre-8.13-1.jason.2.i386 conflicts with file from package pcre-6.6-6.el5_6.1.x86_64

My OS at VPS info is: OS Linux 2.6.18-028stab094.3

Kindly help me to resolve it.

share|improve this question

migrated from stackoverflow.com Sep 25 '12 at 11:25

This question came from our site for professional and enthusiast programmers.

4 Answers 4

You need to update both archs of pcre in the same transaction:

yum update pcre.{i386,x86_64}

provided, of course, you have a 64-bit copy of this newer pcre as well. Failing that, remove pcre.x86_64 first before attempting to upgrade the 32-bit copy of pcre -- though I'd recommend doing it the other way around and keeping only the 64-bit copy.

share|improve this answer
    
Is it right to remove older pcre-6.6 first and then install pcre-8.31. –  Halku Sep 24 '12 at 9:28
    
Might not be a good idea if you have many packages depending on it. In that case, if you're rolling out your own newer pcre package, consider renaming it to pcre8 or something –  michel-slm Sep 24 '12 at 9:57
    
Try configuring this repo as well: jasonlitka.com/media/EL5/x86_64 -- and see if you can then update both pcre together –  michel-slm Sep 24 '12 at 9:58

I had the same error, and was able to solve it by running:

  • yum remove pcre.i386
  • yum update pcre

The list of packages depending on only the i386 architecture was much smaller than for the entire package (mostly kde in my case) - your mileage may vary, please consider the listed dependencies carefully before accepting the removal.

After this, the 64-bit architecture updated properly to the 8.13-1.jason.2 version.

On another note, I also had to run

  • yum reinstall grep

As it seemed to be linking to the no-longer existing library.

share|improve this answer

You've specified both the wrong distribution and the wrong architecture in your third party repository configuration.

.../EL5/i386/...

But, you're running EL6 on x86_64!

So, instead, this should read:

.../EL6/x86_64/...
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.