Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using vSphere and would like to change to a virtual console in the guest OS.

The problem is that when I press CTRL-ALT-F1 my desktop (Ubuntu) changes virtual console and not the guest OS in vSphere.

Does anyone know to do this?

share|improve this question
up vote 4 down vote accepted

Type Alt-F1, Alt-F2 , etc. to obtain the other virtual consoles.

Edit:

Oh, you're accessing VMWare from a non-Windows machine?

I would just disable virtual console switching on your Ubuntu system. For Xorg, it'll be something like the following in the Xorg config file:

Section "ServerFlags"
    Option "DontVTSwitch" "true"
EndSection
share|improve this answer
1  
If the Linux guest is running in console mode, Alt-Fx will only switch the guest and not her local machine. – MikeyB Sep 25 '12 at 16:03
    
@mikeyb Let's hope that the VMWare guest is in console mode :) Good point, though. – ewwhite Sep 25 '12 at 16:04

There is a way this can be done:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1006012

Press CTRL + ALT + Space , press the F1 key (or desired Function key) while still holding down CTRL + ALT

You could also possibly run chcon to change the console, which I've also occassionally found useful before I learned the trick above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.