Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running vmware esx 5.1 and I've created an instance of red hat 5.6 Desktop with a static ip address. When I restart the red hat guest I am able to ping it from another system but then as soon as it gets to the logon page I can no longer ping it. Could it be a matter of a service blocking the network communication?

What can I try or look for?

Thanks.

share|improve this question
1  
Is the firewall enabled? Blocking ICMP echo? Post output of: service iptables status –  Aaron Copley Sep 27 '12 at 13:29
    
Hi Aaron, I already stopped iptables service via: service iptables stop –  b-lieve Sep 27 '12 at 13:37
    
sorry don't see what ICMP echo is –  b-lieve Sep 27 '12 at 13:39
    
If it's stopped, no worries.. That's not it. –  Aaron Copley Sep 27 '12 at 14:32
add comment

4 Answers

Logon page? You're not running the RHEL guest server in text-mode? :)

Either way, make sure you have the updated VMWare tools installed in your guest.

Login to the guest and report on the interface status. What does ifconfig eth0 show?

share|improve this answer
    
Thanks for the reply, no, I'm running RHEL in GUI mode and I tried to keep an eye on the boot details while the VM was booting :) from another machine, the ping command to the RH VM stops just after the xend service starts. I tried disabling it once the machine starts with no success. –  b-lieve Sep 25 '12 at 17:32
    
Do you have the VMWare tools installed? –  ewwhite Sep 25 '12 at 17:35
    
since the vm is not connected here's a printscreen of the command's result: [link]i46.tinypic.com/344y1y0.png –  b-lieve Sep 25 '12 at 17:42
    
@b-lieve Do you have the VMWare tools installed? –  ewwhite Sep 25 '12 at 17:43
    
The vmware tools install is currently in progress, i'm just confused about how could it cause networking issues –  b-lieve Sep 25 '12 at 17:49
show 1 more comment

Your new (!!!) Red Hat 5 workstation uses NetworkManager by default to control access to the network. In its default configuration, it does not bring up the network until after the user logs in.

To fix this, edit the connection within NetworkManager and make sure that "Connect automatically" is checked.

You can also disable NetworkManager and set up the network connection the original way (by editing /etc/sysconfig/network-scripts/ifcfg-eth0 and setting NM_CONTROLLED=no).

share|improve this answer
add comment

If ping stops responding immediately upon the xen service starting, I would guess it is because xen is configuring the Ethernet interface as part of a bridge. Run /usr/sbin/brctl show to see if any bridges are configured. Also, run /sbin/ethtool eth0 to see if a link is detected (i.e. it is not "disconnected" in the VMware settings.)

I would advise disabling the xend service /sbin/chkconfig xend off or even uninstalling the Xen packages yum remove kernel-xen xen-libs. Xen is a completely different Virtual Machine hypervisor to VMware, and unless you really do intend to run one virtualisation system nested within another there's no need for it.

The VMware guest tools should not be necessary for networking (though they are a good idea anyway), unless you have chosen one of the "vmxnet" interfaces. The fact that "eth0" appears in the guest shows you have a driver for the virtual NIC, but it might be worth checking to what type the NIC is set.

share|improve this answer
add comment

VMware tools wouldn't have anything to do this. It's an optional package.

You say it's not the firewall because you stopped it with service iptables stop. Still, I would try iptables -F, which will flush all rules (until you reload the saved config).

Here are some questions / things to try:

1 - Which machine are you pinging from? Is it also on the same ESXi host, or outside the ESXi's virtual switch? What happens when you ping it from another virtual machine on the same host?

2 - What happens when you try to ping something else from this VM?

3 - What does a traceroute show to/from the VM?

4 - Do you have any VLAN id's configured?

5 - Does the MAC address listed in /etc/sysconfig/networking-scripts/ifcfg-eth0 match the adapter mentioned in VM -> Edit Settings?

6 - What Ethernet driver do you have configured for the VM?

7 - Have you tried installing a fresh VM?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.