Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running into a bit of a problem here. I have a mysql server setup on an Ubuntu 12.04 distro. After the initial install I have been using MySQL Workbench to do all my db creation and administrative tasks such as backup\restore etc.

My MySQL Version:

mysql  Ver 14.14 Distrib 5.5.24, for debian-linux-gnu (i686) using readline 6.2

So now we are trying to automate the backup with a custom service. I logged in with putty to the server and tried to login to the MySQL shell using this format.

myuser@skydb1:~$ mysqldump -u root -p mydb
Enter password:
mysqldump: Got error: 1045: Access denied for user 'root'@'localhost' (using password: YES) when trying to connect

Initially I went back and tried to re-authenticate with the Workbench to make sure I was using the correct credentials and I was. Going back to the server and attempting to login via the shell I got the same error.

In the screenshot below you can see that the Workbench indicates that the root user has all appropriate privileges.


The password was removed.

GRANT PROXY ON ''@'' TO 'root'@'localhost' WITH GRANT OPTION
share|improve this question
Login via Workbench and show us the output of show grants for 'root'@'localhost'? – quanta Sep 25 '12 at 16:40
Are you sure that password is the same with 'root'@'%'? – quanta Sep 25 '12 at 16:44
That is a good question. I don't think I went through and verified they were all the same. Now if I am not mistaken the password that is shown in the above query is not the actual password? It is just a hashed password correct? – meanbunny Sep 25 '12 at 16:48
That did it! I went through and reset the password on every root account showing up there and that fixed the problem. – meanbunny Sep 25 '12 at 16:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.