Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had some issues this morning with an EC2 instance so I stopped it and changed it's type and it seemed to unmount one of my drives.

Now, I can't mount anything, including freshly created, attached and formatted drives.

I keep getting the same error:

mount: Stale NFS file handle

I don't even think I'm using NFS ...

Any ideas on how to solve this?

Update & Resolution

Added my own answer below.

share|improve this question
I've google the crap out of this and NOTHING seems to be working. – doremi Sep 25 '12 at 19:54
I realise it's totally unhelpful, but last time i got this error it was about 2 years ago on a server that didn't even use NFS, so in that respect its a total red herring. I can't for the life of me remember what the fix was though. – Sirex Sep 25 '12 at 19:58
Damn. That's exactly my case. I don't use NFS... – doremi Sep 25 '12 at 20:01
At a guess, try running a fsck on the root filesystem. I'm guessing being amazon you'll have to attach it to another instance. That sounds like the sort of thing i'd have tried to fix it. – Sirex Sep 25 '12 at 20:05
I've somehow managed to recover the disk and updated the question with how I was able to resolve it. – doremi Sep 26 '12 at 13:01
up vote 0 down vote accepted

Update & Resolution

As Sirex mentions below, the Stale NFS file handle is a red herring (I'm not using NFS).

Here is what I had to do resolve the issue:

  • STOP the instance running with the OS and Data drive disk attached
  • Detach both the OS and Data volume
  • Make snapshots of each and then create new volumes from the snapshots
  • Create new instance
  • Attach the newly created from snapshot OS and Data Volume and run fsck on both volumes
  • Shutdown new instance and detach all volumes
  • Attach the OS volume to /dev/sda1 to the new instance (making it the boot drive) and the Data volume as /dev/sdf (or whatever you want)
  • Mount your Data volume and pray for no errors
  • If it all works - GO MAKE SNAPSHOTS AGAIN NOW! :)

Hope this helps the next googler.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.