Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get postgis running on my machine. Running brew install postgis seems to have installed postgres 9.2.1 on to my machine. I would like to remove my previous version 9.1.2 to keep my environment clean.

Running brew uninstall postgres removes 9.2.1.

What's the best way to do this?

UPDATE

nai@nyc ~  $ brew versions postgresql
9.2.1    git checkout ed92469 /usr/local/Library/Formula/postgresql.rb
9.2.0    git checkout 2f6cbc6 /usr/local/Library/Formula/postgresql.rb
9.1.5    git checkout 6b8d25f /usr/local/Library/Formula/postgresql.rb
9.1.4    git checkout c40c7bf /usr/local/Library/Formula/postgresql.rb
9.1.3    git checkout 05c7954 /usr/local/Library/Formula/postgresql.rb
9.1.2    git checkout dfcc838 /usr/local/Library/Formula/postgresql.rb
9.1.1    git checkout 4ef8fb0 /usr/local/Library/Formula/postgresql.rb
9.0.4    git checkout 2accac4 /usr/local/Library/Formula/postgresql.rb
9.0.3    git checkout b782d9d /usr/local/Library/Formula/postgresql.rb
9.0.2    git checkout 2c3b88a /usr/local/Library/Formula/postgresql.rb
9.0.1    git checkout b7fab6c /usr/local/Library/Formula/postgresql.rb
9.0.0    git checkout 1168d8f /usr/local/Library/Formula/postgresql.rb
8.4.4    git checkout c32bea0 /usr/local/Library/Formula/postgresql.rb
8.4.3    git checkout 237d1c5 /usr/local/Library/Formula/postgresql.rb
share|improve this question

closed as off topic by Kenny Rasschaert, EEAA, Tom O'Connor, Sven, John Gardeniers Oct 2 '12 at 6:18

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
can you please go to postgresql directory and search for uninstall-postgresql.app? that will uninstall postgresql completely –  Hex Sep 26 '12 at 5:35
    
I dont have that.. –  Nai Sep 26 '12 at 6:54
    
Append the output of brew versions postgresql to your question. –  quanta Sep 26 '12 at 7:06
    
appended output to question –  Nai Sep 26 '12 at 7:27

1 Answer 1

brew uninstall postgresql --force does the trick.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.