Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've added an user with name zenoss, and set export ZENHOME=/usr/local/zenoss in ~/.bashrc under /home/zenoss, and when using echo $ZENHOME, it could show /usr/local/zenoss

When install zenoss, I switched to zenoss and then run install.sh under zenoss-4.2.0/inst, when it tries to run Tests, the error occured.

-------------------------------------------------------
 T E S T S
-------------------------------------------------------
Running org.zenoss.utils.ZenPacksTest
Tests run: 3, Failures: 0, Errors: 3, Skipped: 0, Time elapsed: 0.045 sec <<< FAILURE!
Running org.zenoss.utils.ZenossTest
Tests run: 3, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.71 sec
Results :

Tests in error: 
  testGetZenPack(org.zenoss.utils.ZenPacksTest): No valid ZENHOME could be found.
  testGetPackPath(org.zenoss.utils.ZenPacksTest): No valid ZENHOME could be found.
  testGetAllPacks(org.zenoss.utils.ZenPacksTest): No valid ZENHOME could be found.

Tests run: 6, Failures: 0, Errors: 3, Skipped: 0

[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Zenoss Core ....................................... SUCCESS [27.643s]
[INFO] Zenoss Core Utilities ............................. FAILURE [12.742s]
[INFO] Zenoss Jython Distribution ........................ SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 40.586s
[INFO] Finished at: Wed Sep 26 15:39:24 CST 2012
[INFO] Final Memory: 16M/60M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.8:test (default-test) on project utils: There are test failures.
[ERROR] 
[ERROR] Please refer to /home/zenoss/zenoss-4.2.0/inst/build/java/java/zenoss-utils/target/surefire-reports for the individual test results.
share|improve this question
    
Make sure that .bashrc is properly sourced. –  quanta Sep 26 '12 at 8:13
    
I find out that my setting is just okay, it may be a bug of zenoss's maven test, it should set a path to ZENHOME dynamically, but it sets a .jar file to it. I'm trying to fix that on ubuntu. –  bxshi Sep 26 '12 at 8:29
    
After revisiting this question, I should note that Zenoss is officially not supported on anything other than RHEL/CentOS 5 and 6. If you continue to have trouble, strongly consider using the supported distribution. –  Michael Hampton Oct 15 '12 at 4:27
add comment

1 Answer

Zenoss complained about:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.8:test (default-test) on project utils: There are test failures.

Make sure you actually have it installed:

sudo apt-get install libsurefire-java

If this does not resolve the problem, look at the file it told you to look at:

[ERROR] Please refer to /home/zenoss/zenoss-4.2.0/inst/build/java/java/zenoss-utils/target/surefire-reports for the individual test results.
share|improve this answer
    
That error message is from sunfire, so its already installed –  TheLQ Sep 26 '12 at 14:10
    
Read the rest of the answer. –  Michael Hampton Sep 26 '12 at 14:13
    
I'm saying the first part is probably not correct. The second part though is the proper way to at least see what the problem is –  TheLQ Sep 26 '12 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.