Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to disable ipv6 support completely on debian squeeze 6.0.5. In many other posts I have seen setting the parameter net.ipv6.conf.all.disable_ipv6 = 1 in /etc/sysctl.conf should disable it.

I've set that parameter and rebooted, but netstat -natp shows me that the ntp deamon is still using ipv6:

udp6       0      0 :::123                  :::*      0    7983        3138/ntpd

Is there anything else I need to configure?

share|improve this question
    
ntpd is probably being loaded before procps applies the sysctl (if it does at all). Though as a general rule you shouldn't be disabling IPv6. –  Michael Hampton Sep 26 '12 at 14:18

1 Answer 1

I had this problem trying to get jabber to bind to the ipv4 address. Found the the sysctl.conf didn't work but did have luck adding the kernel command line option ipv6.disable=1

share|improve this answer
    
Can you tell wich exact kernel version you are using? –  markus Sep 28 '12 at 11:24
    
2.6.32-5 amd64, but that boot option should work with 2.6 and up. –  Ed King Sep 28 '12 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.