Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've got a bit of an issue with our test server. It is a windows server 2003 machine with two virtual servers (both windows server 2003) using VM Ware. I'm able to remote into one of the virtual servers through remote desktop, but not the other one.

I can remote to the host machine, but even that machine can't remote to the virtual server.

I used to be able to remote to the other instance, so I know that it should work.

Some more details:

  • I've disabled the firewall on the virtual machine.
  • The virtual machine is not able to ping any node outside of itself, but can connect to the internet just fine.
  • Other computers can ping it, and even access shared files.
  • I've confirmed that terminal services is running.
share|improve this question

4 Answers 4

1) can it RDP to itself?

2) it sounds like more of a networking issue than an RDP issue, based on the ping problem. have you verified its on the same virtual nic, and that all IP information is correct, including DNS, gateway, netmask, etc?

share|improve this answer
    
All of the network settings look fine to me. I did an ipconfig /all on both the host and vm and they looked the same. –  Jesse Jul 20 '09 at 22:01
    
The VM instnace can not remote to itself, nor can the host remote to the VM instance. –  Jesse Jul 20 '09 at 22:01
    
test the other one for that rdp behavior - it should work. have you checked group policy to verify its not restricted in some way there? note that some apps (especially MSFT, im looking at you system center) may change that setting without asking you. –  Devnull Jul 21 '09 at 13:53

I know it seems like a dumb question but have you enabled remote administration on the second machine? It is off by default.

Properties of the MyComputer on the desktop or start menu, then the "Remote" tab. "Enable Remote Desktop on this computer" must be checked.

share|improve this answer
    
Remote desktop is enabled. –  Jesse Jul 20 '09 at 21:39

Make sure the network adapter on the VM is set to Bridged and not NAT.

share|improve this answer
    
The adapter is set to bridged. –  Jesse Jul 20 '09 at 21:40

Vmware server can act as a VNC server for all of the VMs (without the VMs even knowing about it)

Just enable the VNC server on the virtual machines and set them all to run on a different port. My guess is that the virtual machines and your host machine are all fighting for the same port.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.