Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On SL6.1 I am trying to yum update glibc and it's failing I think with a conflict of sources, but I'm not too sure. I don't really know how to parse the yum error, but here it is:

# yum update glibc
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.x86_64 0:2.12-1.80.el6_3.3 will be updated
---> Package glibc.x86_64 0:2.12-1.80.el6_3.5 will be an update
--> Processing Dependency: glibc-common = 2.12-1.80.el6_3.5 for package: glibc-2.12-1.80.el6_3.5.x86_64
--> Running transaction check
---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.3 will be updated
--> Processing Dependency: glibc-common = 2.12-1.80.el6_3.3 for package: glibc-2.12-1.80.el6_3.3.i686
---> Package glibc-common.x86_64 0:2.12-1.80.el6_3.5 will be an update
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.80.el6_3.3.i686 (@sl-security)
           Requires: glibc-common = 2.12-1.80.el6_3.3
           Removing: glibc-common-2.12-1.80.el6_3.3.x86_64 (@sl-security)
               glibc-common = 2.12-1.80.el6_3.3
           Updated By: glibc-common-2.12-1.80.el6_3.5.x86_64 (sl-security)
               glibc-common = 2.12-1.80.el6_3.5
           Available: glibc-common-2.12-1.25.el6.x86_64 (sl)
               glibc-common = 2.12-1.25.el6
           Available: glibc-common-2.12-1.47.el6.x86_64 (sl-security)
               glibc-common = 2.12-1.47.el6
           Available: glibc-common-2.12-1.47.el6_2.5.x86_64 (sl-security)
               glibc-common = 2.12-1.47.el6_2.5
           Available: glibc-common-2.12-1.47.el6_2.9.x86_64 (sl-security)
               glibc-common = 2.12-1.47.el6_2.9

Any help given is greatly appreciated. The sl and sl-security repositories are not those provided by scientificlinux.org, rather a static mirror with only the relevant packages provided by a research partner.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

It looks like:

  • yum wants to update glibc-common-2.12-1.80.el6_3.3.x86_64 to glibc-comon-2.12-1.80.el6_3.5.x86_64
  • the glibc-common:i686 package needs to stay in lockstep with glibc-common:x86_64
  • the latest version of glibc-common:i686 available is glibc-common-2.12-1.80.el6_3.3.i686
  • hence, it cannot resolve the two

So it appears that glibc-common-2.12-1.80.el6_3.5.i686 is missing from the update site. Resolve that and things should be OK.

share|improve this answer
    
Thanks @MikeyB. My solution in the end is to remove glibc.i686 since I don't really need it. –  Duncan Macleod Sep 26 '12 at 17:49
    
OK, that works as well! By the way, convention is to upvote and accept my answer if it solved your problem. ;) –  MikeyB Sep 26 '12 at 20:01
    
I have accepted your answer assuming it is correct (looks fine, but have not verified), but cannot upvote (reputation). –  Duncan Macleod Sep 26 '12 at 20:14
    
Thanks and welcome to the site! –  MikeyB Sep 27 '12 at 13:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.