Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have set up a Windows Server 2008 R2 Server with Terminal Services. I am able to successfully log into the server using Remote Desktop Connection. However, many of my users, both admins and non-admins, are receiving an error message when logging in. The error message is:

"The system cannot find the file specified. This initial program cannot be started: D:\folder\file.exe. Please consult help for more information"

Here's what I've done so far, and none of it works... - Deleted the user's local profile on the Server

  • Check the user's RDC connection settings on their local PC to make sure no initial programs are specified

  • Searched the registry for the name of the exe that Windows is attempting to execute

  • Searched the server's hard drive for any mention of the file that Windows is attempting to execute

  • Had these users run RDC from my machine and remotely connect to the server. Error message still pops up

My guess is that there is something that userinit.exe is being instructed to run. How it is getting this instruction is being me.

If anyone has any ideas or thoughts on how to fix this, your help would be much appreciated.

Thanks for your time.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Look at the Environment tab on the user account properties in ADUC.

Look at the GPO for both the users and the servers. There's a TS/RDS setting under both Computer Configuration and User Configuration for starting a program on connection. There's also a System\Logon GPO setting that can be configured to run programs at logon for both Computer Configuration and User Configuration.

share|improve this answer
    
Thanks, I'm humbled...yet again. –  Justin Largey Sep 27 '12 at 3:49
    
Glad to help... –  joeqwerty Sep 27 '12 at 4:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.