Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I followed the documentation on installing Zabbix from source and it is working great, except that zabbix_server and zabbix_agentd do not automatically start when the system is booted.

I found that the following entries were made for me

/etc/services

zabbix-agent    10050/tcp                       # Zabbix Agent
zabbix-agent    10050/udp
zabbix-trapper  10051/tcp                       # Zabbix Trapper
zabbix-trapper  10051/udp

When I issue the commands

zabbix-server

zabbix-agentd

from a shell, both start just fine.

What is the correct procedure to ensure that zabbix_server and zabbix_agentd automatically start when the Ubuntu server is booted?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

The following suggestion from the Zabbix forum worked for me:

Copy the init.d scripts to the right spot:

sudo cp misc/init.d/debian/zabbix-server /etc/init.d
sudo cp misc/init.d/debian/zabbix-agent /etc/init.d

Set the correct permissions and set Zabbix to start when the machine boots:

sudo chmod 755 /etc/init.d/zabbix-server
sudo update-rc.d zabbix-server defaults
sudo chmod 755 /etc/init.d/zabbix-agent
sudo update-rc.d zabbix-agent defaults
share|improve this answer

One thing you might want to consider:

When installing from source, the different zabbix components (such as zabbix_server & zabbix_agentd) do take their configuration files from /usr/local/etc instead of /etc/zabbix.

I therefore use symbolic links from /etc/zabbix to /usr/local/etc.

# ln -s /etc/zabbix/zabbix_agentd.conf /usr/local/etc/zabbix_agentd.conf # ln -s /etc/zabbix/zabbix_server.conf /usr/local/etc/zabbix_server.conf

If not, the zabbix components will start on boot, but totally unconfigured.

If I need to start the components from the command line, I need to add the option -c or --config too.

# zabbix_server --config=/etc/zabbix/zabbix_server.conf # zabbix_agentd --config=/etc/zabbix/zabbix_agentd.conf

Hope this helps. Jord

share|improve this answer
    
That presumably depends on how the build is configured, OP want might to go over that. –  vonbrand Mar 26 '13 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.