Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attempting to install the HP LeftHand P4000 Storage Replication Adapter in VMWare Site Recovery Manager 5.1 with vSphere 5.1

However, the LeftHand SRA keeps stating that SRM is not installed, even when it is.

The VMware Site Recovery Manager must be installed before the HP P4000 SRA for VMware SRM 5 can be installed.

Is there any way I can convince it that it is installed?

share|improve this question
up vote 5 down vote accepted

Yes. The problem is that the SRA installer is looking in HKLM\SOFTWARE\Wow6432Node\VMware, Inc.\VMware vCenter Site Recovery Manager for its registry keys, but that's not where they are in 5.1 - they are just in HKLM\SOFTWARE\VMware, Inc.\VMware vCenter Site Recovery Manager:

enter image description here

This is an easy fix. Export HKLM\SOFTWARE\VMware, Inc.\VMware vCenter Site Recovery Manager from the above registry key on your SRM server, open the .reg file in notepad, add the \Wow6432Node\ into the path, and then re-import it.

Voila, an exact duplicate of your registry entries in the correct place. Now you can install:

enter image description here


enter image description here

If you continue to have issues, please refer to Dave's additional answer below.

share|improve this answer

The above is not complete, though it set me on the correct path, there were more keys that the SRA was looking for. I had to add a few keys to get this to work: below is what you will need. Tested this a couple of different ways and this worked: add the following entries to the registry and it should work:

[HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware vCenter Site Recovery Manager]
"InstallPath"="C:\\Program Files (x86)\\VMware\\Infrastructure\\Virtual Infrastructure Client\\Plugins\\VMware vCenter Site Recovery Manager\\"

Create a .reg file from the above, copy and paste this, then import and you should be fine. Again, deleted all the keys, did them one-by-one and tried again to find valid configuration.

share|improve this answer
Interesting, thanks. I didn't have this particular issue myself, but thanks for making us aware. – Mark Henderson Oct 8 '12 at 19:25

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.