Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two Cisco 2901 GWs, each has an HWIC-2T interface module. I want to set them up back-to-back to send network traffic between PCs and Phones connected to my GWs over this link.

I have CAB-SS-X21FC (DCE) and CAB-SS-X21MT (DTE) cables connected together, then connected to Serial0/2/0 on each GW.

This is the config I have so far...

GW1

configure terminal
frame-relay switching
interface Serial 0/2/0
  encapsulation frame-relay
  frame-relay intf-type dce
  ip address 10.10.1.50 255.255.255.0
  frame-relay interface-dlci 101

(have tried adding clock rate too, although not sure what clock speed to include)

GW2

configure terminal
interface Serial 0/2/0
  encapsulation frame-relay
  ip address 10.10.1.51 255.255.255.0
  frame-relay interface-dlci 101

I then try and ping 10.10.1.51 from GW1 (and vice versa) but no luck.

Am I missing some config items? Also, what is the best way to check if I am getting connectivity (i.e. a debug setting on the router)

share|improve this question

1 Answer 1

up vote 0 down vote accepted

First off, if this is truly a point-to-point interface, there's absolutely no reason to use frame-relay encapsulation. Either let the interfaces default to hdlc or set "encapsulation ppp" for a much simpler config.

The best way to see if these are working is the "show interface" command. "show interface brief" will list all of your interfaces in a table.

If this has to remain a frame-relay interface, use the various "show frame-relay" commands (show frame-relay map, show frame-relay lmi, etc) to see if LMI and frame-relay control messages are being properly sent and received.

More info can be found here: http://www.cisco.com/en/US/tech/tk713/tk237/technologies_tech_note09186a008014f8a7.shtml#topic1

share|improve this answer
1  
In a frame-relay back-to-back set up I think the OP needs to disable LMI and configure one end as the clock source, no? –  joeqwerty Sep 27 '12 at 18:44
    
I disabled FR and used HDLC. I made sure I set the clock speed on the DCE router only (thanks joequerty) and it all started working. Thanks for your help –  Ian Oct 11 '12 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.