Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed Apache2 (with mod_ssl enabled) on SUSE Linux Enterprise Server 11 (x86_64) (patchlevel 1), using YaST. Once installed, I tested whether everything works fine so far. SSL also worked fine.

Just 'apache2ctl start' was enough to make everything working.

Then I installed mod_jk and applied the following configuration changes to make it work.

/etc/sysconfig/apache2 (added JK module)

APACHE_MODULES="... ... ... ... ...jk"

/etc/apache2/httpd.conf (included mod_jk.conf)

Include /etc/apache2/mod_jk.conf

/etc/apache2/mod_jk.conf (new file)

JkLogFile                       /var/log/apache2/mod_jk.log
JkWorkersFile           /etc/apache2/mod_jk/workers.properties
JkShmFile                       /etc/apache2/mod_jk/mod_jk.shm

# Set the jk log level [debug/error/info]
JkLogLevel                      info

# Select the timestamp log format
JkLogStampFormat        "[%a %b %d %H:%M:%S %Y] "

mod_jk.log & mod_jk.shm files were also created.

/etc/apache2/mod_jk/workers.properties (new file)

worker.list=jira
worker.jira.type=ajp13
worker.jira.host=127.0.0.1
worker.jira.port=8009

Once everything is done, I've restarted Apache using the following command,

apache2ctl restart

Then I observed that SSL is not working. When checked with telnet, I observed that port 443 is not open.

In listen.conf, if I specify port 443 bypassing 'IfDefine' and 'IfModule' conditions, then SSL works properly. This is likely the 'SSL' flag is not passed to Apache. I did not make this a persistent change as I thought it might not be the correct practice.

I checked /etc/sysconfig/apache2 to see if this has been altered, but it is there. Although this flag is enabled, Apache won't start with SSL support.

APACHE_SERVER_FLAGS="SSL"

Finally, I had to start Apache using the following command,

apache2ctl -D SSL -k start

And my question is, why did Apache (or apache2ctl) fail to start with SSL when I have installed and correctly configured mod_jk, and no other configuration changes were applied?

Have I missed anything?

Thanks in advance.

-- Shaakunthala

share|improve this question

1 Answer 1

Got this answer from a friend,

use "rcapache2 start" to start the server.. then it'll work. otherwise it would not consider the SSL flag set on /etc/sysconfig/apache2

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.