Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have setup a brctl bridge on Ubuntu with the following deployment:

Cisco router -> Linux bridge -> client computer

The bridge forward the following packets types: ARP,STP, but doesn't forward IP.(I see that it get IP packets in eth0 but dosnt forward to eth1)

Trying brctl br0 stp off (and on) doesn't help.

Trying to activate both ethernet cards with promisc mode doesn't help either.

Set edge to 0 (and set max edge to 0) doesn't help either.

brctl setfd bridgename time , dosnt help.

Ebtables dosnt install on the bridge computer, so this is not problem of ebtables filtering.

When I replace the router with a simple computer that simulates simple TCP request the bridge forwards the IP packets, so I suspect STP.

The bridge was set like this:

iptables -X
iptables -F
ifconfig eth0 0.0.0.0 up
ifconfig eth1 0.0.0.0 up
brctl addbr br0
brctl addif br0 eth0 eth1
ifconfig br0 up
share|improve this question
    
Try giving your ethernet devices a real ip not 0.0.0.0. –  Matt Sep 17 '13 at 1:12

1 Answer 1

Bridge forwards ethernet packets, not just IP:

forwarding delay: http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge#Forwarding_delay

ethernet filtering: http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge#No_traffic_gets_trough_.28except_ARP_and_STP.29

share|improve this answer
    
ebtables dosnt installed and setfd dosnt help :( –  Avihai Marchiano Sep 27 '12 at 16:39
    
Are you using vlans? Which distro? "bridge-nf-call-iptables - pass (1) or don't pass (0) bridged IPv4 traffic to iptables' chains." –  GioMac Sep 28 '12 at 9:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.