Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to know how I would properly mount my windows harddrives in my VM ( debian ) and share it with samba so that other users can access it without a password.

I'm going this way because I would like to access the folders on my mediacenter and with windows i had no luck at all to get this to work, now I've got it working but it keeps asking me for a username and password which is very anoying.

in /etc/fstab I wrote:

//192.168.0.1/e /mnt/e cifs username=mywinuser,password=xxx,dmask=777,fmask=777,uid=mylinuxuser,guid=mylinuxuser,rw

in /etc/samba/smb.conf

[tv]
  browseable = yes
  path = /mnt/e/TV
  guest ok = yes
  read only = yes
  create mask = 0700

in my smb.conf I tried setting

security = share 
user = nobody

but that didn't work out.

share|improve this question
add comment

1 Answer

I'm using Ubuntu 12.04, and didn't have to mess with the Samba conf. Here's my fstab line if it helps:

//192.168.0.150/z  /media/z  cifs  username=###,password=###  0 0

According to some documentation I read, the mask flags are only necessary if you're super concerned about the permissions your Linux box sees on the CIFS share. I'm not (and run as root, it's a test VM), so I omitted them and it works fine.

Maybe you should try resetting your Samba configs to their defaults and using the simpler fstab line?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.