Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have multiple websites setup using Nginx and Apache, but when I try to add a vhost based PHP directive using fastcgi_param PHP_VALUE , the value get added to all of my vhosts. Checking the value of the PHP parameter from PHP-CLI remain the actual one for whole server. e.g.

I used fastcgi_param PHP_VALUE "memory_limit=512M" for a domain based nginx config, but it will be propagated to all domains on server. The 'php -i | grep memory_limit' show 128M though

Not sure what I am missing

share|improve this question
    
It would be helpful to see your nginx.conf and vhost configuration files the diagnose the issue. You can obfuscate domains and IPs if you feel you need to. –  pjmorse Oct 5 '12 at 15:11
add comment

1 Answer

Don't confuse php-cli with PHP.

php -i | grep memory_limit is not the same as <?php phpinfo(); . Its very likely they use different php.ini files.

For your actual issue, where are you defining the value, in the common fcgi_params file or setting explicitly in each vhost location directive.

share|improve this answer
    
I know that php.ini used for PHP-CLI and PHP-GUI can be different. I have added the fatsci_param under vhost location directive. –  user138814 Sep 28 '12 at 7:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.