Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have the following commands in /etc/rc.local

chmod 666 /dev/fuse  
chmod +x /usr/bin/fusermount  
/bin/su someuser -c "/usr/bin/sshfs someuser@someserver:/usr/local/storage /usr/local/storage_remote -o nonempty -o reconnect"  

If I run them from command line, as root, they work.
If I reboot the server they won't run from /etc/rc.local.
I try to figure out what I do wrong but I don't have console access and I couldn't find any errors in /var/log related to sshfs.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I figured out what it missed

  1. sudo addgroup root fuse
  2. sudo addgroup someuser fuse

Also there was an error in /etc/rc.local that prevented the lines with sshfs to be executed.

share|improve this answer

You should consider using fstab instead to mount filesystems including Fuse based ones. This will stop your box trying to mount network fileststems, for example, if your network is down.

See: http://www.debuntu.org/2006/04/27/39-mounting-a-fuse-filesystem-form-etcfstab

This should be applicable for all Linux distros (excluding package commands)

share|improve this answer
    
Thanks but I would really like the system to try to mount again automatically if a there is a problem. –  Alex Flo Oct 1 '12 at 6:52
    
@AlexFlo I'm not sure how putting it rc.local will allow it automatically remount. –  Alastair McCormack Oct 1 '12 at 7:58
    
its simple, just add "-o reconnect" as in my description above and it will take care to reconnect when the other server is up. –  Alex Flo Oct 2 '12 at 8:48
    
so add reconnect to the options column in fstab. For example: sshfs#my-remote-user@my-remote-host:/home/my-remote-user /my-local-filesystem/remotefs fuse nonempty,reconnect 0 0 –  Alastair McCormack Oct 2 '12 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.